Support > Installation

Installing Script Basic V2.1

(1/2) > >>


I have been using ScriptBasic on and off for five years now. Originally V1.29 and then V1.30. These have run under various Linuxes – RedHat followed by SuSe 9.0 and then 10.0. I am now trying to set up V2.1 under SuSe 10.2. This is the first time I have had problems but I would be the first to admit it may be because I am more of an applications programmer than an OS guru. I  downloaded ScriptBasic from: -

After unzipping I ran “./setup” which came up with “Invalid option”. Therefore I ran   “perl --unix $*” which it calls. Towards the end of the output generated in came up with

“scriba executable FAIL
sbhttpd executable FAIL
libscriba library FAIL”

before some dll and lib fails which do not seem uncommon.

SuSe` was installed, for me, from a single CD rather than the more usual 4 CD set, or single DVD. I found initially that ‘C’ and ‘make’ were missing and have retrospectively installed these. I am now totally stuck. Any ideas? Is there any fairly comprehensive documentation that might help me or might it be related to the SuSe 10.2 subset that was installed?

Thank you in anticipation.

If your using GCC 4.x then you need to download the ScriptBasic changes  that Peter made for the depreciated compiler functionality.


I also wanted to mention that if your compiling the source on Linux, you need to convert it to linefeed only. There is a convert Perl script that does that for you. (see install instructions for *nix)



A belated thanks for this information. There were a few additional minor issues before I could compile successfully plus I noted that the syntax check is a bit tighter. Now I am working through and testing the software suite.


Michael  :)


Good to hear that you achieved a clean compile.

What version of *nix are you using?



[0] Message Index

[#] Next page

Go to full version