Author Topic: Debugger progress  (Read 119360 times)

GSAC3

  • Guest
Re: Debugger progress
« Reply #15 on: October 06, 2014, 11:10:49 pm »
John:

Thanks John -- I'll give it a try.

Don
 

Support

  • Administrator
  • *****
  • Posts: 1
    • View Profile
Re: Debugger progress
« Reply #16 on: October 07, 2014, 07:43:06 am »
I created a Bitbucket Repository for Dave's Script BASIC COM and IDE/Debugger. Dave's Github repository (maintained by him) has aspirations for a VB6 Script BASIC scripting engine as an ActiveX control. 

The Bitbucket repository has been updated with the Script BASIC 2.2 version and a new Windows installer created.

Attached is the SB COM object interface viewer.

import com.inc

'on error resume next

oExcelApp = CreateObject("Excel.Application")

if oExcelApp = 0 then
    print "Failed to create Excel Object do you have it installed?"
    return
end if

print "Typename = ", TypeName(oExcelApp), "\n"

print "Launching DescribeInterface dialog...\n"
DescribeInterface oExcelApp

print "Shutting down Excel and releasing object...\n"
CallByName(oExcelApp, "Quit")
ReleaseObject(oExcelApp)

print "Script complete!\n"
 

C:\ScriptBasic_Control-master\engine\COM_Extension_DLL>scriba typeinfo.sb
Typename = _Application
Launching DescribeInterface dialog...
Shutting down Excel and releasing object...
Script complete!

C:\ScriptBasic_Control-master\engine\COM_Extension_DLL>


Here is a thread showing the Script BASIC COM extension module creating an Excel Spreadsheet.
« Last Edit: October 07, 2014, 09:59:26 am by support »

GSAC3

  • Guest
Re: Debugger progress
« Reply #17 on: October 07, 2014, 07:49:39 pm »
JOHN:

Either I am doing something wrong or else there is a bug in the Debugger.

When i load a SB script (for example testmath.sb) an click on the RUN button, everything seems to execute OK.  But if I then click on the scroll bars on the right side of the two windows or if I click anywhere in either window or on any of the program control buttons the Debugger freezes with the "PROGRAM NOT RESPONDING" messages and I have to do several ctl-dels to kill the hung up process "test".

Don

P.S.  I have the same problem when using the previous version before your weekend update.


Support

  • Administrator
  • *****
  • Posts: 1
    • View Profile
Re: Debugger progress
« Reply #18 on: October 07, 2014, 08:45:23 pm »
What Windows OS are you running on Don? It seems to work fine in my XP VirtualBox. I'll try it on my Windows 7 64 bit partition and see if I have issues there. Thanks for the feedback.

Hint: I always click on the window (editor/debugger, vars, ...) before scrolling. (mouse/arrows or scrollbars) See if that helps. I would also make sure you're running the latest VB redistributables. thread on the subject

Note: I had to use IE to download this VB6 update as Firefox gave a network error.
« Last Edit: October 08, 2014, 01:16:44 am by support »

Support

  • Administrator
  • *****
  • Posts: 1
    • View Profile
Re: Debugger progress
« Reply #19 on: October 07, 2014, 11:38:07 pm »
Don,

I'm here on Windows 7 64 bit and the Script BASIC IDE/Debugger seems to work fine here as well. Just like on XP.


GSAC3

  • Guest
Re: Debugger progress
« Reply #20 on: October 08, 2014, 12:35:52 am »
JOHN:

I am the Debugger on WINDOWS-XP.

Don

Support

  • Administrator
  • *****
  • Posts: 1
    • View Profile
Re: Debugger progress
« Reply #21 on: October 08, 2014, 01:23:09 am »
Don,

I just applied the VB6 SP6 accumulative updates under XP and regenerated the SBDebug.exe program. Can you give this a try and see if it helps?

John

GSAC3

  • Guest
Re: Debugger progress
« Reply #22 on: October 08, 2014, 05:43:15 pm »
John:

You'r fix did not seem to help at all.

Once I start a RUN and after the execution has finished, the debugger keeps running and can't be stopped.  The debugger hangs in running status and I get the UNRESPONSIVE program message if I click anywhere, even o the STOP button.

Don

Support

  • Administrator
  • *****
  • Posts: 1
    • View Profile
Re: Debugger progress
« Reply #23 on: October 08, 2014, 06:01:24 pm »
Do you have VB6 on your system? If not do you have the latest VB6 runtime redistributables installed?

As mentioned before, it works flawlessly on my XP VirtualBox and on my Win7 64 bit partition. How old is your PC? I have asked others to give it a try and report back if they are seeing your symptoms.

Status

Aurel (O2 forum) - XP - IDE and SAPI COM example works.
« Last Edit: October 08, 2014, 07:34:32 pm by support »

GSAC3

  • Guest
Re: Debugger progress
« Reply #24 on: October 08, 2014, 08:43:17 pm »
John:

1.  Don't have VB6 installed on system.

2.  Do have VB6 redistributable files installed.

3.  System is DELL XPS-1710 about 7 yrs old.

Don

Support

  • Administrator
  • *****
  • Posts: 1
    • View Profile
Re: Debugger progress
« Reply #25 on: October 08, 2014, 09:04:43 pm »
Are you running XP SP3? What is the speed (mhz/ghz) of your CPU? How much memory do you have?


GSAC3

  • Guest
Re: Debugger progress
« Reply #26 on: October 09, 2014, 12:04:42 am »
1.  XP SP2

2.  INTEL CORE 2
     T7600 @ 2.33 GHZ
     2.0 GB RAM

Don

Support

  • Administrator
  • *****
  • Posts: 1
    • View Profile
Re: Debugger progress
« Reply #27 on: October 09, 2014, 03:03:01 am »
Quote
1.  XP SP2

I would highly recommend finding a SP3 update. Your XP system is seriously out of date.